Installing Lexmark Printer 2600 Series on Linux

In this tutorial I will show how to install the Lexmark printers 2600 series. In my case I have one printer model x2695 and it is up and running on Ubuntu 9.04, even the scan feature. Looks like there is a lack of information about Lexmark drivers, even in the OpenPrinting project the 2690 series is tagged as “Paperweight”.

First download the driver here, or in this backup link. Extract it and, on the terminal, type

./lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh

Now you will be guided by screens to …

… the error that happened in the last screen, “The installer package is not supported by your system. Installer will exit.”. In order to know where this message came from, and to try to understand what happened I needed to check the source of the installer. In order to do that I needed to go to the terminal and type:

./lexmark-inkjet-08-driver-1.0-1.i386.tar.gz.sh --noexec --target lexmark

It created a folder called lexmark containing the source of the installer. There I found the run.lua file that was the source the message that was displayed in the error. As soon as I analysed the code in this script, I changed a piece of it:

vim /lexmark/config/run.lua

on the line 16 from

g_usetar = false

to

g_usetar = true

So, I needed to run the installer again but using the changed file:

cd lexmark
./startupinstaller.sh

Now the instalation was finished succesfully, and I could even use XSane to scan documents. You can find here the output from the succesful installation because maybe it can gives you some insights if your installation was not fine. Now, in my printers configuration screen I have two 2600 printers, one created by the installer, and another created when the system found the printer right after the driver was installed:

Well, I had not even one printer working, now I have two :¬)

Advertisements