Building QtOctave 0.8.2 from source

The current version of qtoctave provided by apt-get is 0.8.1. I experience some problems that freeze my qteditor. So I check for a bug and found that there is a newer version, which can have some bug fixes. However, when installing QtOctave I have to turnaround the following issues presented in the QtOctave blog:

1. Include in files below:

sed '1 i #include \' qtoctave_pkg/src/main.cpp
sed '1 i #include \' qtoctave/src/search_dialog.cpp.

2. Change the order of the CMakefileList.txt to:

TARGET_LINK_LIBRARIES(qtjs
${QT_QTUITOOLS_LIBRARY}
${Qt4_LIBRARIES}
${QT_QTCORE_LIBRARY}
${QT_QTGUI_LIBRARY}
${QT_QTXML_LIBRARY}
#${QT_QTSVG_LIBRARY}
${QT_QTSCRIPT_LIBRARY}

rather than

TARGET_LINK_LIBRARIES(qtjs
${Qt4_LIBRARIES}
${QT_QTCORE_LIBRARY}
${QT_QTGUI_LIBRARY}
${QT_QTXML_LIBRARY}
#${QT_QTSVG_LIBRARY}
${QT_QTUITOOLS_LIBRARY}
${QT_QTSCRIPT_LIBRARY}

3. Compile cmake in the current directory instead of create a directory build to insteas as is described in readme.

qtoctave-0.8.2$ cmake .
qtoctave-0.8.2$ make
qtoctave-0.8.2$ make install

See ya

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: